[smokeping-users] Running smokeping inside a Virtual Machine

Schneider, Andreas Andreas.Schneider at Vishay.com
Wed May 16 17:02:20 CEST 2007

i ran Smokeping on Debian on a M$ VirtualServer(free and yes M$ said
that Linux will not work, but it does - very well)
and smokeping is running fine too.


Von: smokeping-users-bounces at lists.oetiker.ch
[mailto:smokeping-users-bounces at lists.oetiker.ch] Im Auftrag von Frank
Gesendet: Mittwoch, 16. Mai 2007 14:19
An: smokeping-users at lists.oetiker.ch
Betreff: [smokeping-users] Running smokeping inside a Virtual Machine

Hi smokeping Experts,


I like to know if you ever tried running smokeping inside a VMware
virtual machine (Debian Linux guest OS).


The effect I see is that when running smokeping on a physical box the
network is fine, but when running smokeping from inside a virtual
machine a lot of packets appear to be dropped. However, the network
applications itself all seem to be fine.


My guess is that maybe smokeping is very time sensitive. The virtual
machine clock has time jumps and irregularities in the millisecond range
(up to 200 ms). So how well does smokeping cope with a system clock
which does not constantly show the correct time? Could this explain that
some packets appear as dropped (they could just have arrived at
unexpected times)?


Thanks a lot in advance,



Best Regards.

Frank Wegner
http://www.vmware.com <http://www.vmware.com> 

VMware Global Inc., Branch Office Germany

Place: Unterschleissheim, Freisinger Str. 3, County Court Munich HRB

President: Diane Greene


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/smokeping-users/attachments/20070516/f8762035/attachment.htm 

More information about the smokeping-users mailing list