[smokeping-users] Upgrade 2.1.1 -> 2.2.3 smokeping hangs

Steven Bytnar smbsmokepingusers at bytnar.net
Wed Oct 10 18:18:44 CEST 2007

Back on Sep 10, 2007, Vinny Abello complained about a hang in Smokeping when
upgrading from 2.1.0 to 2.2.3.

Well, I just tried upgrading from 2.1.1 to 2.2.4 and discovered what the
problem is.  echoping and don't mix well. When comparing the source
differences, I noticed that after 2.1.1, was changed to
in several of the probes.

In the directory lib/Smokeping/probes, these files:
need to have changed back to to workaround what seems
like a hang. The hang turns out to be a really long delay.

% time echoping -A -h /
Elapsed time: 0.032856 seconds
0.001u 0.003s 0:00.14 0.0%      0+0k 0+0io 0pf+0w

That's .14 seconds to run the command test.

% time echoping -A -h /
Can't connect to server (Operation timed out)
0.001u 0.002s 1:14.78 0.0%      0+0k 0+0io 0pf+0w

That winds up being 1 minute 14 seconds for every EchoPing command test.

% time echoping -A -t 1 -h /
Timeout while connecting
0.000u 0.002s 0:01.20 0.0%      0+0k 0+0io 0pf+0w

Adding "-t 1" reduces the delay to just over 1 second.
I don't want any delay during startup, so I changed all references
back to

It would be nice if smokeping actually printed useful information about
intialization when --debug is used. A debug message that said
"Testing EchoPingHttp" would've helped me find the problem much quicker.


Vinny Abello wrote:
> Tried it and it was taking forever... :)
> I was just hoping someone would say, "Oh, when that happens, look to this as the problem." No such luck I guess. :-/
> Tobias Oetiker wrote:
> > Hi Vinny,
> > 
> > try divide and conquer
> > 
> > cheers
> > tobi
> > 
> > Yesterday Vinny Abello wrote:
> > 
> >> Hi all,
> >>
> >> I'm sure I'm missing something somewhere, but I'm trying to upgrade from Smokeping 2.1.0 (from the FreeBSD ports) to Smokeping 2.2.3 (manually as the port isn't yet updated). I've done this successfully in the past with earlier versions a few times while waiting for the port to be upgraded. This time around for some reason, after copying all the new files and customizing them to reflect the same paths as my previous ones, I cannot successfully start the Smokeping daemon. It doesn't throw any errors at all. It simply hangs. I cannot get any output even with the debugging switch. If I point it to the included config.dist file in the 2.2.3 distribution with a few minor changes to reflect the location of things on my system, smokeping will start. I cannot see what the difference is except for all my monitors. I can't figure out where it's failing because of the hang and no error messages in any logs or to the screen. I also tried adding all the new features into the config to
 > r
> >  e
> >> flect the base one. I additionally tried commenting out parts of my config trying to get it to work, but I'm getting nowhere fast. There must be a better way to troubleshoot this. My only thought is something with one or more of the probes I have defined as the config.dist only references fping.
> >>
> >> Any suggestions on where to find out what's happening or ideas?
> >>
> >> Thanks!
> >>


More information about the smokeping-users mailing list