[smokeping-users] Smokeping packet loss issues

Israel Brewster israel at frontierflying.com
Fri Oct 12 01:01:58 CEST 2007

Whops, forgot to post this back to the list. Also some corrections to  
what I sent initally. Sorry :P

On Oct 11, 2007, at 12:27 PM, Tobias Oetiker wrote:

> Israel,
> how have you set the -t timeout parameter ? Note there is a similar
> discussion on the list just now ...
> cheers
> tobi

Yeah, I noticed that. That discussion would seem to imply however  
that delayed packets ARE acknowledged by fping, even if the RTA is  
very high, and that the timeout parameter only applies to how long it  
waits after sending the last packet. The other thing that I noticed  
in that discussion was that it referenced smokeping 2.0.5, which  
apparently doesn't have a timeout option. As I have also tried fping  
directly from the command line with the same results, however, this  
is not an issue in my situation.

I have set the timeout parameter in smokeping with the timeout=2.0  
parameter, as follows:

+ FPing

binary = /usr/local/sbin/fping
timeout = 2.0

I have also tried directly from the command line by giving it the -t  
2000 parameter but this doesn't appear to work any better.

Israel Brewster
Computer Support Technician
Frontier Flying Service Inc.
5245 Airport Industrial Rd
Fairbanks, AK 99709
(907) 450-7250 x293

> -- 
> Tobi Oetiker, OETIKER+PARTNER AG, Aarweg 15 CH-4600 Olten
> http://it.oetiker.ch tobi at oetiker.ch ++41 62 213 9902

More information about the smokeping-users mailing list