[smokeping-users] TCPPing probe doesn't generate data

G.W. Haywood ged at jubileegroup.co.uk
Mon Jun 16 22:28:56 CEST 2008

Hi there,

On Tue, 17 Jun 2008, David Tomic wrote:

> So you're saying that I should end up with:
> ---------------------------------------------
>         next unless /^\S+\s+:\s+[\d\.]/; #filter out error messages from
> tcpping
>         @times = split /\s+/;
>         my $ip = shift @times;
>     print STDERR @times;
>         next unless ':' eq shift @times; #drop the colon
>     print STDERR @times;
> ---------------------------------------------


> I've done all that, but I'm still not seeing anything in the apache log
> file either.

Er, are you using speedy_backend and if so did you restart it?  :)
You can just kill it.

> Just out of curiosity, did you actually get/read my message wondering if
> it was some sort of permissions problem?


>  FWIW I'm running Ubuntu 8.04, and just installed Smokeping through
>  their software repository.  As part of that installation, it seems to
>  have created a seperate 'smokeping' user + group, so could that
>  possibly have something to do with the problem?

I don't think so.  Any user should be able to send packets out of the
network interfaces, and that's all that's needed for things like ping
unless you want to flood-ping the network for example, which you
don't.  Of course there might be something screwy with the Ubuntu
setup, but I imagine they've got it fairly well under control.  When I
first saw your posts I used Debian's 'apt-get install' to fetch the
tcptracetoute package to one of my Debian boxes, and I saw exactly the
same symptoms that you described.  I fixed it using the hack that I
sent to you so I was reasonably confident of the cause of the problem.

Of course I've been known to be wrong. :(  I've assumed that you've been
able to get graphs using other probes, for example FPing.  If not, you
should definitely try to do that.  The users and permissions will all be
the same for the other probes.

>  I'm still [relatively] new to the whole Linux world

I can tell. :)

>  Is there an easy way to check and/or rule out any sort of permission
>  error as the source of my problem?

Not one simple way, generally speaking.  But you're getting debug info
from the Smokeping scripts that log into /var/log/messages, and Apache
will have permission to write to its own logs, so I don't think it's
an issue yet.  We need to see what is happening to the information
that's being returned - it's getting lost somewhere - which means we
need to follow it through the system step-by-step.  There aren't many
steps, but unfortunately it's a few orders of magnutude slower by email.



More information about the smokeping-users mailing list