[smokeping-users] No data being displayed for slave machine

David Tomic young_einstein at internode.on.net
Fri Jun 20 10:36:15 CEST 2008

Hi guys ... another day, another problem!

I've tried setting up another machine to run as a slave, but I just 
cannot for the life of me seem to get it up and running properly.

I've got everything installed & configured, but the graphs just aren't 
registering any data for the slave machine.

The thing is, if I run the slave in --debug mode, then everything 
appears to be working perfectly:

david at david-slavebox:~$ sudo smokeping --master-url= --cache-dir=/var/smokeping/ --shared-secret=/etc/smokeping/secret.txt --debug
Sent data to Server and got new config in response.
### parsing dig output...OK
### assuming you are using an tcpping copy reporting in milliseconds
Smokeping version 2.004000 successfully launched.
Not entering multiprocess mode with '--debug'. Use '--debug-daemon' for that.
Curl: probing 0 targets with step 300 s and offset 235 s.
FPing: probing 2 targets with step 300 s and offset 235 s.
TCPPing: probing 0 targets with step 300 s and offset 235 s.
DNS: probing 0 targets with step 300 s and offset 235 s.
FPing: Executing /usr/bin/fping -C 21 -q -B1 -r1 -i10
FPing: Got fping output: ' : 8.80 0.64 0.67 0.65 0.88 3.56 0.70 0.61 0.67 0.63 0.64 0.63 0.63 0.74 0.63 0.64 0.95 0.63 0.62 0.66 0.64'
FPing: Got fping output: ' : 0.45 0.31 0.28 0.24 0.28 0.27 0.57 0.62 0.31 0.70 0.40 0.37 0.24 0.28 0.26 2.94 0.49 5.20 0.25 0.38 0.38'
Sent data to Server. Server said OK

The master has created the .rrd file for the slave, and it's showing it 
on the graph legend, but it's just reporting 'nan' for all its data.

I can't seem to find any error messages being reported on the master 
setup, so I've really got no idea where the actual problem is on this one?

My efforts in Google as well as searching through this list seemed to 
turn up a comments from people about making sure that smokeping.cgi has 
got write permission to the cache directory.

Does anyone know if that could be where I'm going wrong here [and if so 
exactly what I need to be doing to fix it]?

IE - Exactly which files/folders, on which machines, need which permissions.

Otherwise ... any other help/suggestions would be most welcome!


More information about the smokeping-users mailing list