[smokeping-users] EchoPingHttp

Schneider, Andreas Andreas.Schneider at Vishay.com
Sat Jun 28 14:05:24 CEST 2008

im not very familiar with the echoping stuff. But i found out that i use version 6.0.2 on Debian 4.0
I tried with the -R option but nothing changed. Still got "HTTP/1.1 401 Unauthorized". 
Do i have to change the echoping.pm ? But what should i change?
Kind regards,


Von: smokeping-users-bounces at lists.oetiker.ch im Auftrag von G.W. Haywood
Gesendet: Sa 28.06.2008 12:30
An: Schneider, Andreas
Cc: smokeping-users at lists.oetiker.ch
Betreff: Re: [smokeping-users] EchoPingHttp

Hi there,

On Fri, 27 Jun 2008, Schneider, Andreas wrote:

> i want to monitor a SharePoint Website with EchoPingHttp. But i always get 100% packet loss.
> When i run echoping from commandline with the -v switch i got message ...401 Unauthorized.
> OK, the SharePoint is a local Intranet and works together with ActiveDirectory authentication.
> So, is there a way to send authorization, so that echopinghttp is not refused?

If I were doing this I wouldn't want to send authorization, because it
might add a significant amount of unnecessary overhead.  Instead, I'd
request a URL which would cause a 301 response from the server.  I'd
use EchoPingHttp's 'accept_redirects' option so that a 301 is treated
as a normal response, not an error.

The accept_redirects option gives the '-R' switch to echoping, so you
need a recent version of echoping which will understand it.  The version
that I use on Debian Etch doesn't, and I had to patch EchoPingHttp.pm to
prevent the switch from being used.



smokeping-users mailing list
smokeping-users at lists.oetiker.ch

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/smokeping-users/attachments/20080628/aef67ff0/attachment-0001.html 

More information about the smokeping-users mailing list