[smokeping-users] Smokeping graphs randomly stop generating

G.W. Haywood ged at jubileegroup.co.uk
Fri Sep 5 08:27:14 CEST 2008

Hi there,

On Thu, 4 Sep 2008, Westlake, Simon wrote:

> I've recently upgraded my servers to Ubuntu 8 and have been experiencing
> a strange problem with Smokeping. I have Smokeping distributed across a
> couple of different servers and I'm having the same problem on both
> servers. At random intervals (could be hours or days, but is typically
> hours) the graphs will just stop generating. The only log messages I
> have when they die is 'MARK'. The daemon appears to be running. If I do
> an /etc/init.d/smokeping restart, the graphs begin generating again. My
> config is fairly basic, I'm only using fping/hping probes.

It isn't clear to me whether the graphs aren't being generated or the
ping processes aren't pinging.  Perhaps you could investigate further
and let us know what you find.  Have you tried running Smokeping with
the debug option for a few days?  If not I'd recommend it.  I run it
that way routinely, disc space is cheap and you can rotate the logs.

How long had you been running Smokeping before the upgrade to Ubuntu 8
and on what system/distribution?  As you're having the same problem on
both servers, it seems likely that it's, er, a hard software problem
which should be relatively easy to track down.  I'm willing to bet that
it isn't random, we just don't know what events trigger it yet. :)



More information about the smokeping-users mailing list