[smokeping-users] trouble setting up speedy cgi

Layla Nahar laylanahar at gmail.com
Sat Jul 9 07:08:21 CEST 2011


I have tried to install Speedy CGI on my system using source code and
using binaries.  Both lead to errors.  I am using Centos 4.5.  I would
be most grateful if someone can help me get speedy CGI and thus
smokeping itself up and running.

With Speedy installed from binaries, when I try to open a simple
test.cgi  with shebang line  "#!/usr/bin/speedy"  I get a 500 Internal
Server Error.
apache error log shows:
[Fri Jul 08 23:32:18 2011] [error] [client]
/usr/bin/speedy: error while loading shared libraries: libperl.so:
cannot open shared object file: No such file or directory
[Fri Jul 08 23:32:18 2011] [error] [client] Premature end
of script headers: speedytest.cgi

(If I replace "#!/usr/bin/speedy"  with "#!/usr/bin/perl"  the page
can be opened as expected).
I have tried updating perl using yum update perl,  but it looks like
I'm already at the latest version.

I installed two different versions,  both give the same failure
 rpm -i perl-CGI-SpeedyCGI-2.22-1.2.el4.rf.i386.rpm
 rpm -i RedHat-9-speedycgi-2.22-1.i386.rpm.

I had earlier tried to install speedy cgi (2.22) from source code, but
it failed on the memleak test, viz

t/be_memleak..........ok 1/2 mem usage went from 6000K to 8048K in 1000 runs
t/be_memleak..........FAILED test 2
        Failed 1/2 tests, 50.00% okay
t/be_memleak.t                2    1  50.00%  2
Failed 1/33 test scripts, 96.97% okay. 1/73 subtests failed, 98.63% okay.
make[1]: *** [test_dynamic] Error 255

I had tried a workaround like this:
sysctl -w net.core.wmem_default=65536

but Speedy CGI still failed the memory leak test.

Any help would be much appreciated,
Thank you,

More information about the smokeping-users mailing list