[smokeping-users] ERROR: opening '/tmp/smokeping-ms/data/mysite1/myhost1.rrd': No such file or directory

Layla Nahar laylanahar at gmail.com
Thu Jul 28 04:43:29 CEST 2011

Josh -

thank you very much for your response.

I have yet to do anything with crontab on this system.   I was going
to follow your suggestion, and I checked in the smokeping directory
but the only reference I find to cron seems to be for tSmoke, about
sending email updates on the system status.    Could you tell me what
you mean by the cron job?

Also I've been trying to figure out smokeping creates the initial rrd
file, but I'm still puzzled by this.  Could you tell me where I should
look to understand that better?

thanks again


On 7/27/11, Joshua Andrews <joshua_andrews at gemvision.com> wrote:
> Layla:
> Not sure, but it "feels" more like the file doesn't exist which means
> smokeping may not have created the data.  Have you already setup the cron
> job and given it time to run some data before trying to load the links on
> the site?
> Joshua Andrews > IT Administrator Gemvision Corporation 706 East River Drive
> Davenport, IA 52803 p 800.357.6272 x143  f 563.884.8181
> http://www.gemvision.com
> -----Original Message-----
> From: smokeping-users-bounces+joshua_andrews=gemvision.com at lists.oetiker.ch
> [mailto:smokeping-users-bounces+joshua_andrews=gemvision.com at lists.oetiker.ch]
> On Behalf Of Layla Nahar
> Sent: Wednesday, July 27, 2011 6:35 AM
> To: smokeping-users at lists.oetiker.ch
> Subject: [smokeping-users] ERROR: opening
> '/tmp/smokeping-ms/data/mysite1/myhost1.rrd': No such file or directory
> Hi,  I'm getting this error:
> When I click on a menu item (eg 'MySite1) I get the failure.
> ERROR: opening '/tmp/smokeping-ms/data/mysite1/myhost1.rrd': No such
> file or directory
> Can somebody tell me how to fix this?
> I set tmp/smokeping-ms/data to permission 777 and I set ownership of
> both 'smokeping-ms' and 'data' to smokeping:smokeping.  I also tried
> setting ownership to apache:apache but I still get the failure above.
> I am doing everything as root.  I started smokeping as user root.
> root is able to run RRDTool and make a new *.rrd file
> user smokeping is able to run  "rrdtool --help"  but gets a permission
> denied error when trying to create an *.rrd file.
> Is the source of
> ERROR: opening '/tmp/smokeping-ms/data/mysite1/myhost1.rrd': No such
> file or directory
> in the permissioning?
> How can I fix this error?    I can set up new users and groups if
> necessary.  I've noticed references to user 'www' but I have yet to
> set up this user.   I guess that it is related to apache.  It would be
> great if someone could clarify the role of www.
> thank you very much
> LN
> _______________________________________________
> smokeping-users mailing list
> smokeping-users at lists.oetiker.ch
> https://lists.oetiker.ch/cgi-bin/listinfo/smokeping-users

More information about the smokeping-users mailing list