[smokeping-users] Slave to Master connection over IPv6

Jean jean at wedebugyou.com
Sun Mar 31 13:19:08 CEST 2013

Hello Jester,

I confirm this problem too. If anyone find a solution, I am willing to 
hear it.

In my setup the master runs on debian and the slaves runs on FreeBSD 
and CentOS.



On 2013-03-30 16:21, Jester 2.0 wrote:
> I am setting up SmokePing with a master and 2 slaves.  During my
> configuration, I ran into an issue that looks a bug.
> I configured smokeping to connect to my master that has only an IPv6
> address.  At startup, I get this error:
> WARNING Master said 500 Can't connect to gold.example.net:80 [1] (Bad 
> hostname)
> I then configured Slave to connect to a master that has both v4 and
> v6 address and the connection worked.  Watching the connection, I see
> that it connected over v4, not v6 as it should prefer to.
> Anyone else able to confirm this?
> Links:
> ------
> [1] http://gold.example.net:80
> _______________________________________________
> smokeping-users mailing list
> smokeping-users at lists.oetiker.ch
> https://lists.oetiker.ch/cgi-bin/listinfo/smokeping-users

More information about the smokeping-users mailing list