[smokeping-users] smokeping2.6.11 -- 500 internal server error

Gregory Sloop gregs at sloop.net
Thu Jul 2 21:33:57 CEST 2015

1) Set SEL to permissive or disable. [At least for testing.]
(I'm not sure what you did about SEL, but do the above if you haven't already.)

2) Who owns/has permissions for the CGI? root only? Make sure Apache can serve it. [i.e. has permissions.]

Watching/reviewing the log files for Apache, and/or the debug output from smokeping is almost always quite useful. [And if you can't find what's wrong after doing so, that's the next thing I'd ask you for...]

Your problem, while not related to RRD read/writes [the typical problem for most people], still looks like a permissions issue to me - but the apache logs should tell you something.

Also, see the general FAQ that solves most problems:

Once you have a base setup working, then you can turn SEL back on, if you like.


I tried that and also ran through the steps posted on http://www.wedebugyou.com/2012/11/how-to-install-and-configure-smokeping-on-centos-6/

at this point this is the error that now pops up in the logs:

 (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
 Premature end of script headers: smokeping.fcgi

has anyone seen this?  thx 

On Thu, Jul 2, 2015 at 11:50 AM, Joseph Kieffer <joseph.kieffer at gmail.com> wrote:
I ran into this as well and found that it was SELinux blocking http connections. I stopped running the server I had this issue with but I have a note that I used "setbool httpd_can_network_connect=1" to fix this for my install.

On Thu, Jul 2, 2015, 1:31 PM Christian Vo <christian.vo at gmail.com> wrote:
hi all,
this is a new install of smokeping2.6.11 on centos6.6

compilation and installation ran fine without any issues.

the smokeping process itself is running...

however  all attempts to access  the url  (http:<webserver>/smokeping/smokeping.cgi) errors out and apache error log shows the following

(13)Permission denied: exec of '/opt/smokeping/htdocs
/smokeping.fcgi' failed

Premature end of script headers: smokeping.fcgi

I'm stuck here, not sure where else to look.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.oetiker.ch/pipermail/smokeping-users/attachments/20150702/bca841ee/attachment-0001.html>

More information about the smokeping-users mailing list