[smokeping-users] TCPPing - glob -- how to fix this?

Gregory Sloop gregs at sloop.net
Mon Nov 26 20:12:35 CET 2018

TCPPing generally requires root.
Thus, when you run at the CLI, [presumably as root] it works.
When you run it as smokeping it doesn't.

Google "setuid" for general direction as how to solve it.
I think something like [chmod u+s /location/of/some/tcpping-binary] will set the UID bit properly. 



Hi all 

just to add ,  if I run smokeping --debug-daemon,  the graph generates....wth... 

On Mon, Nov 26, 2018 at 9:50 AM Christian Vo <christian.vo at gmail.com> wrote:
hi Igor,

thanks for the tip -->  I re-installed tcptraceroute and now
1) from smokeping --debug , I can see proper data collected and smokeping seems to graph the value as expected (good)
2) however, when I run smokeping as a daemon,  it doesn't seem to graph (bad) 

the newer tcptraceroute was installed into /usr/local/bin,  and I tried sym-link to /usr/sbin/tcptraceroute
tcpping is still there as /usr/sbin/tcpping

I'm not sure it's a tcpping issue at this point, but I checked  the imagecache and datadir , perfmissions seem to be ok.
as a test (new target anyhow) I deleted the rrd and imagecache folder for this target, but new graph still doesn't show anything.
I can see timestamp update on the rrd file but nothing gets generated in the graph.

any ideas?  it could be something really simple that I missed, but I'm drawing blanks =(


On Sun, Nov 25, 2018 at 12:08 PM Маценко Игорь <Aikanaro at live.ru> wrote:
Hi Christian, 

It has something to do with the tcptraceroute package, I had the same issue. I remember what I did was re-installed tcptraceroute package and it worked. 


On Nov 25, 2018, at 2:59 PM, Christian Vo <christian.vo at gmail.com> wrote:

Hi Igor,  

Both tcptraceroute and tcpping are in the same folder. I notice issue seems to be related to the script being called with -c option? If I run  the command manually with this flag, it doesnt return the values.. not sure where I'd fix this, anyone? 

On Wed, Nov 21, 2018, 8:53 PM Маценко Игорь <aikanaro at live.ru wrote:
Hi Christian,
I had similar issue, make sure you have installed packed called tcptraceroute/traceroute(that’s solved my issue) on the box that you are running smokeping instance from. I am 100% sure that’s the issue. 
Ubuntu: sudo apt-get install tcptraceroute

Also, have you tried running smokeping in debug mode? It could shed some light.

From: smokeping-users <smokeping-users-bounces+aikanaro=live.ru at lists.oetiker.ch> on behalf of Christian Vo <christian.vo at gmail.com>
Sent: Wednesday, November 21, 2018 10:23:48 PM
To: smokeping-users at lists.oetiker.ch
Subject: [smokeping-users] TCPPing - glob -- how to fix this? 
(Sorry if it's been asked, but google search didn't clearly explain how to resolve this =()

I'm trying to implement a probe using TCPPing 
I have the script working along with tcptraceroute (i.e. works via CLI fine)

however, smokeping isn't generating any data against the target host,
and from debug allI see is the following:

TCPPing: forks 5, timeout for each target 301
TCPPing: Executing /usr/sbin/tcpping -C -x 20 host.somewhere.com 443
TCPPing: Received: GLOB(0x2e388e8)
TCPPing:  host.somewhere.com: got 
(Nothing else afterwards related to TCPPing, just FPING targets and related results)

I tried to search on " TCPPing: Received: GLOB(0x2e388e8)"
which got me this: https://github.com/oetiker/SmokePing/issues/60
but I'm not sure if I'm missing something...

my Probe definition:

+ TCPPing

binary = /usr/sbin/tcpping
forks = 5
step = 300
offset = 50%
timeout = 15

my Target definition:

probe = TCPPing
menu = zoom
title =  host.somewhere.com 
host =  host.somewhere.com 
port = 443

Pls help,


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.oetiker.ch/pipermail/smokeping-users/attachments/20181126/ccb0519d/attachment.html>

More information about the smokeping-users mailing list