[mrtg] Re: SNMP error

Daniel R . Kilbourne drk at voyager.net
Wed Aug 29 19:22:46 MEST 2001

I am running mrtg 2.9.17 with absolutley no problems monitoring pretty much anything possible on several *nix flavors (SunOS, Solaris, FreeBSD, Linux)

Have you tried doing an snmpget on the OIDs in question to see what is returned? It looks to me like it will not be an integer.....

Craig Baird extolled:
> >From everything I've been able to tell, there's something broken in MRTG
> 2.9.x when it comes to connecting to Linux boxes running an SNMP daemon.
> For some reason they give the error you mentioned.  2.9.x seems to connect
> fine to just about any other device, but on Linux it just plain doesn't
> work.  This fact remains regardless of the SNMP daemon in use.  I tried
> both cmu-snmpd and ucd-snmpd.  Results were the same with both.  Also,
> snmpwalk worked fine, but MRTG just won't work.  I tried several
> incantations of 2.9 with the same results.  I finally went with 2.8.12,
> which works beautifully.  So, unless I'm missing something, which is very
> possible, you'll need to use 2.8.12 until this problem with the 2.9 series
> gets fixed.

Daniel R. Kilbourne
daniel.kilbourne at corecomm.com
CoreComm Systems Engineering

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list