[mrtg] Disk Performance Windows 2000 and MRTG

Kenneth Tilsted (KET) KET at ramboll-informatik.dk
Tue Dec 6 07:40:19 MET 2005

I have installed MRTG 2-12-2 and monitoring successfully both Diskspace,
CPU and Memory. But I have a problem about monitoring the following
counters in Windows (and their OID's):

AverageDiskQueueLength : 






I have tried both Compaq's CPQIDA.mib and Microsoft's
"Windows-nt-performance" without luck (I might see the name on the
counter but it is like not supported by MRTG)


The server monitored is and Proliant running either W2K or W2K3 and my
MRTG Server is running W2K.


But I receive snmpget error - like the OID is unknown. I have used
several MIB Browsers to check out the MIBs to have monitored. But it is
like the OID is unsupported. I have tried to use the command LoadMIBs
and then load the "Windows-nt-performance.mib" but it doesn't seem to
have any effect. I used this command: loadMIBs :


Here is the list  of the errors received when running my cfg file:


SNMPGET Problem for

1.8 sysUptime sysName on public at xxx.xxx.xxx.xxx::::::v4only

 at mrtg line 1921

SNMP Error:

Received SNMP response with error code

  error status: noSuchName

  index 1 (OID:

SNMPv1_Session (remote host: "xxx.xxx.xxx.xxx" [xxx.xxx.xxx.xxx].161)

                  community: "public"

                 request ID: 1584029039

                PDU bufsize: 8000 bytes

                    timeout: 2s

                    retries: 5

                    backoff: 1)

 at C:/mrtg-2.12.2/bin\..\lib\mrtg2/SNMP_util.pm line 490


ERROR: Target[xxx-io][_IN_] ' $target->[31]{$mode} ' did not eval into
defined data

ERROR: Target[xxx-io][_OUT_] ' $target->[31]{$mode} ' did not eval into
defined data


The above error is for percenetIdleTime


Does anyone have a clue about how to proceed to have the above 5
counters monitored in MRTG. At the moment both physical and logical
counters are welcome. I have tried almost everything over the last few
month but do not have any more ideas? Or how am I using the
loadMIBs-command wrong? Thanks all.




Kenneth Tilsted



Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://lists.ee.ethz.ch/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the mrtg mailing list