[mrtg] cfgmaker - "cleanhostkey" error & mrtg - "undefined subroutine" error

Darko Cabro dark at logikom.net
Tue Dec 13 11:16:06 MET 2005

I've recently upgraded to the latest version of mrtg (been using 
2.10.something for about 3 months without problems) and tried to use the 
old config files, but unsuccessfuly.
I had the following error in mrtg log file:

Undefined subroutine &main::readfromcache called at /usr/bin/mrtg line 1854.

After that I've tried to create a new config file but got a new error 
with cfgmaker :

Can't locate object method "cleanhostkey" via package "communitym at host:" 
(perhaps you forgot to load "community at host:"?) at /usr/bin/cfgmaker 
line 227.

Tried cfgmaker with only needed options but still getting the same error.

Community and host values are correct, and snmpwalk command is working 
properly for that host.

Using perl version 5.8.5, and have libpng, gd and zlib libraries.. Mrtg 
installation was successful without errors.. (source install with only 
prefix specified).

So, any ideas on this problem?
Any help appreciated.

Darko Cabro

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://lists.ee.ethz.ch/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the mrtg mailing list