[mrtg] mrtg 2.16.2 & rrdtool 1.3.7

Lyle Giese lyle at lcrcomputer.net
Sun Sep 6 15:14:22 CEST 2009

I am building a new server to replace my monitoring server and I have
always had a practice of adding stuff from source.  I built this on SLES
10 sp1 32 bit kernel.

I downloaded mrtg v2.16.2 and rrdtool 1.3.7(I was already running
rrdtool on the previous server).  I never could get rrdtool 1.3.7
installed.  No matter how hard I tried, it kept complaining that
pangocairo was not installed.  I have pango 1.25.5 installed in
/usr/local with a symlink in /usr/lib point to libpango in
/usr/local/lib and still no go.  Any ideas?

I finally did some research and found that pango (or is it pangocairo?)
was new to rrdtool 1.3.x.  I dropped back to rrdtool 1.2.28 and
everything complied and is running.

Is there hope for me to get to rrdtool 1.3.x or should I just stay at

Lyle Giese
LCR  Computer Services, Inc.

This looks like the area of issue in the config.log for rrdtool 1.3.7:

configure:30759: checking for cairo-ps.h
configure:30766: result: yes
configure:31114: checking for pango_cairo_context_set_font_options in
configure:31149: gcc -o conftest -g -O2 -D_GNU_SOURCE
-fno-strict-aliasing -Wall -std=c99 -pedantic -Wundef -Wshadow
-Wpointer-arith -Wcast-align -Wmissing-prototypes -Wmissing-declarations
-Wnested-externs -Winline -Wold-style-definition -W  -fPIC -DPIC 
-I/usr/local/include/cairo -I/usr/local/include/libpng12   
-L/usr/local/lib -L/usr/X11R6/lib     conftest.c -lpango-1.0  -lcairo
-lcairo -lcairo -lm  -lcairo -lSM -lICE -lpixman-1 -lfreetype
-lfontconfig -lpng12 -lz -lm -lXrender -lX11 -lXext   >&5
conftest.c: In function 'main':
conftest.c:104: warning: old-style function definition
/tmp/ccONVJIc.o: In function `main':
/home/addons/rrdtool-1.3.7/conftest.c:105: undefined reference to
collect2: ld returned 1 exit status
configure:31155: $? = 1
configure: failed program was:
| /* confdefs.h.  */

<stuff deleted>

| #define HAVE_ISFINITE 1
| /* end confdefs.h.  */
| /* Override any GCC internal prototype to avoid an error.
|    Use char because int might match the return type of a GCC
|    builtin and then its argument prototype would still apply.  */
| #ifdef __cplusplus
| extern "C"
| #endif
| char pango_cairo_context_set_font_options ();
| int
| main ()
| {
| return pango_cairo_context_set_font_options ();
|   ;
|   return 0;
| }
configure:31173: result: no
configure:31314: checking for pkg-config
configure:31341: result: pkg-config
configure:31564: WARNING:
* I found a copy of pkgconfig, but there is no pangocairo.pc file around.
  You may want to set the PKG_CONFIG_PATH variable to point to its
configure:31597: WARNING:
* I could not find a working copy of pangocairo. Check config.log for
hints on why
  this is the case. Maybe you need to set LDFLAGS and CPPFLAGS appropriately
  so that compiler and the linker can find libpango-1.0 and its header
files. If
  you have not installed pangocairo, you can get it either from its
original home on


  You can find also find an archive copy on


  The last tested version of pangocairo is 1.17.

       LIBS=-lcairo -lcairo -lcairo -lm  -lcairo -lSM -lICE -lpixman-1
-lfreetype -lfontconfig -lpng12 -lz -lm -lXrender -lX11 -lXext 
   LDFLAGS= -L/usr/local/lib -L/usr/X11R6/lib   
  CPPFLAGS= -I/usr/local/include/cairo -I/usr/local/include/libpng12 


More information about the mrtg mailing list