[mrtg] mrtg 2.16.2 & rrdtool 1.3.7

Steve Shipway s.shipway at auckland.ac.nz
Mon Sep 7 00:23:32 CEST 2009

> I downloaded mrtg v2.16.2 and rrdtool 1.3.7(I was already running
> rrdtool on the previous server).  I never could get rrdtool 1.3.7
> installed.  No matter how hard I tried, it kept complaining that
> pangocairo was not installed.  I have pango 1.25.5 installed in
> /usr/local with a symlink in /usr/lib point to libpango in
> /usr/local/lib and still no go.  Any ideas?

One problem a lot of people come up against is that (when installing from RPM in particular) you need to install the development Pango and Cairo as well as the runtime; IE the .h and .a files as well as the .so.  So you'll also need to incluse symlinks for these; I's suggest instead, though, that you use the options to 'configure' to specify the directory where you have actually installed Pango, rather than symlinking all over the place.  Then it will work.

People with RedHat can easily install the pango-devel and cairo-devel packages to get what they need, I suspect SLES has similar packages available?

This is what I have installed under RHEL5 for clean compilation -


More information about the mrtg mailing list