[mrtg] mrtg 2.16.2 & rrdtool 1.3.7

Lyle Giese lyle at lcrcomputer.net
Mon Sep 7 00:43:25 CEST 2009

Steve Shipway wrote:
>> I downloaded mrtg v2.16.2 and rrdtool 1.3.7(I was already running
>> rrdtool on the previous server).  I never could get rrdtool 1.3.7
>> installed.  No matter how hard I tried, it kept complaining that
>> pangocairo was not installed.  I have pango 1.25.5 installed in
>> /usr/local with a symlink in /usr/lib point to libpango in
>> /usr/local/lib and still no go.  Any ideas?
> One problem a lot of people come up against is that (when installing from RPM in particular) you need to install the development Pango and Cairo as well as the runtime; IE the .h and .a files as well as the .so.  So you'll also need to incluse symlinks for these; I's suggest instead, though, that you use the options to 'configure' to specify the directory where you have actually installed Pango, rather than symlinking all over the place.  Then it will work.
> People with RedHat can easily install the pango-devel and cairo-devel packages to get what they need, I suspect SLES has similar packages available?
> This is what I have installed under RHEL5 for clean compilation -
> pango-devel-1.14.9-5.el5_3
> pango-1.14.9-5.el5_3
> cairo-1.2.4-5.el5
> cairo-devel-1.2.4-5.el5
> Steve
I think this one is deeper than that. SLES does have rpm's, but 10 is a
bit older and the version of Pango with SLES 10 is not new enough for
mrtg. SLES 11 has some fundmental changes that I don't like and did not
want to take the time to work through.

Thanks for answering this one. I am more concerned about the lastupdate
parameter now.

Now to go sulk as Nagios went from html to php based and it's a 'minor'
footnote in a sub-minor version change...

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/mrtg/attachments/20090906/5f28ede7/attachment.htm 

More information about the mrtg mailing list