[mrtg] ...MRTG intermittently recording zero values instead of valid values

Barron Hulver Barron.Hulver at oberlin.edu
Thu Oct 7 16:41:28 CEST 2010

We are using MRTG in native mode (no RRDTool).  I'm aware of the integer 
constraint and am fairly certain it is not this.  I've tried graphing as 
a rate by running the cron job once per hour and multiplying the number 
of pages by 3600 in order to keep an integer. (I realize there is a 
perhour option as well.)  Alternatively, I've also tried graphing using 
a gauge so I just pass the integer to MRTG and it should store it as-is 
but it does not.

Any other thoughts?  I think we'll try upgrading the MRTG software 
before switching to RRDTool.


On 10/7/10 4:07 AM, Steve Shipway wrote:
> If you're using MRTG in native mode (no RRDTool) then it is not capable of working with anything other than integers.
> If you're graphing pages printed, and polling every 5min, you might be getting zeros because it keeps rounding down.
> I'd suggest you try switching to using MRTG with RRDTool instead of native mode, if possible, as it is much more flexible for this sort of data.  We graph pages printed (per minute) on our networked printers successfully, although this value can fall below 1 on average.
> Steve
> Steve Shipway
> University of Auckland ITS
> UNIX Systems Design Lead
> s.shipway at auckland.ac.nz
> Ph: +64 9 373 7599 ext 86487

More information about the mrtg mailing list