[rrd-developers] Re: rrdtool is now using freetype and libart

Alex van den Bogaerdt alex at slot.hollandcasino.nl
Wed Jan 16 23:20:38 MET 2002

Tobias Oetiker wrote:

> It is all in the cvs archive and tonight a current snapshot will
> show up in the beta directory of the rrdtool/pub tree ...

Downloaded it.

> I have not yet tried building what is in cvs, but this would only
> be a matter of some files which I have messed up while checking in
> ...

Tried to build it.

> The new version also contains all new configure and friends which
> will only work with the latest and greatest automake, libtool and
> autoconf.

Redhat 7.1 is definitely too old.  The links pointing to
/usr/pack/libtool-1.4.2-to/share/libtool/ don't exist.

Redhat 7.2 (unmodified) was the next try.  Result:
[alex at home rrdtool-2002-01-16]$ ./MakeMakefile
   + find . -name Makefile
   + xargs rm
   rm: too few arguments
   Try `rm --help' for more information.
   + find . -name Makefile.in
   + xargs rm
   rm: too few arguments
   Try `rm --help' for more information.
   + libtoolize --automake
   + aclocal
   + autoheader --warnings=all
   Usage: autoheader [-h] [--help] [-m dir] [--macrodir=dir]
          [-l dir] [--localdir=dir] [--version] [template-file]
   + automake --foreign --add-missing --force-missing --copy
   automake: unrecognized option -- `--force-missing'
   Try `automake --help' for more information.
   + autoconf
   autoconf: configure.in: No such file or directory

The problem with "find . -name Makefile | xargs rm"
could probably be avoided.  Dunno how.

Versions available in stock RH7.2:

libtool:  1.4    (not 1.4.2)
automake: 1.4-p5 (not 2.12)
autoconf: 2.13   (not 2.52)

A search on the RH site proves to be rather disappointing, the
"newest" libtool is version 1.3.5-8 (yeah right, then why 1.4 ?).

Anyway, do you really need bleeding edge tools?

 / alex at slot.hollandcasino.nl                  alex at ergens.op.het.net \
| work                                                         private |
| My employer is capable of speaking therefore I speak only for myself |
| Technical questions sent directly to me will be nuked. Use the list. | 
| http://faq.mrtg.org/                                                 |
| http://rrdtool.eu.org  --> tutorial                                  |

Unsubscribe mailto:rrd-developers-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-developers-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-developers
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-developers mailing list