[rrd-developers] Re: Problem with perl (RRDs::graph) on XP, u sing Jun 10 snapshot

Calvert, Kerry kerry.calvert at intel.com
Fri Jun 14 02:10:23 MEST 2002

Just to clarify what I mean when I say "perl crashes": 
When I run "nmake test" in the perl-shared area, the test harness runs
base.t. When base.t gets to the RRDs::graph statement, XP puts up a dialog
box telling me that perl must close and would I like to send a note to
Microsoft. I say no and the test harness then reports that the test is
dubious.  Is this what you call a runtime exception?

Changing the libs was what I was trying, without much success. Building RRD
using the .NET IDE, I selected the release configuration, which is MT.  The
default in the makefile is MD, which I've changed to MT and also ML.  I've
also set LIBC explicitly to msvcrt and libc, and disabled optimization.
There are more combinations, but I'm not clear on direction.  I'm using the
.NET command prompt to run the makefile, which means that I have the same
LIB environment as the IDE.

The only way that RRDs::graph works is without the free statements.
RRDs::info, which I added to base.t, has the same problem and the same fix.
To insure I hadn't made some other change, I redownloaded RRD and rebuilt
with a minimum of changes.

-----Original Message-----
From: Jake Brutlag [mailto:jakeb at microsoft.com]
Sent: Thursday, June 13, 2002 4:38 PM
To: Calvert, Kerry; RRD_DEVS (E-mail)
Subject: RE: [rrd-developers] Re: Problem with perl (RRDs::graph) on XP,
using Jun 10 snapshot

> RRDs::graph works if I comment out all of the "free(mem)" 
> statements in RRDs.xs where mem is allocated by rrd. This 
This is free(calcpr), correct? This pointer points to the image data.
The library fucntion rrd_graph() does allow the calling environment to
allocate its own memory, but if you don't (as RRDs.xs does not), it will
do it for you. free(), calloc(), etc are libc functions. I wonder if the
problem is libc compatibility. Are you creating rrd.lib (produced in
src\release) with the same libc as you specified in ntmake.pl?

I still think the problem is related to the graph command in base.t
generating errors, because I get a runtime exception on my system.
Before you tried debug compilation and mucking with RRDs.xs were you
able to execute a simple graph command?


Unsubscribe mailto:rrd-developers-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-developers-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-developers
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-developers mailing list