[rrd-developers] Building rrdtool v1.3.8 on win32

Barrie0482 barrie0482 at gmail.com
Sun Jun 28 11:17:28 CEST 2009

I am working on writing a "rrdtool build howto" for win32. My motive for this
is to be able to use the ruby  rrdtool bindings on a windows  platform. My
aim is for this process to be easily repeatable for others to follow as new
versions of rrdtool are released.

Using the WIN32-BUILD-TIPS.txt included with the rrdtool source, I have been
able compile and run rrdtool v1.3.5 using Visual C++ 2008 Express edition. I
needed to modify the code for a couple of the source files. My C programming
skills are limited, so I'm not sure if what I did was best practice. I was
also able to compile the code for the ruby bindings. 

The rrdtool executable seemed to work OK with the limited tests I ran. The
ruby bindings worked OK for some of the functions, but I had some  problems
with other functions. Some of the forum information seemed to point to fixes
in later releases.

Tobi sugessted that I should always use the latest release. So I have
started with rrdtool v1.3.8

I followed the instructions WIN32-BUILD-TIPS.txt using using Visual C++ 2008
Express edition.

I received the following error when I tried to build rrdlib.

1>------ Build started: Project: rrdlib, Configuration: Debug Win32 ------
1>..\src\rrd_restore.c(917) : error C2664: 'get_long_from_node' : cannot
convert parameter 3 from 'time_t *' to 'long *'
1>        Types pointed to are unrelated; conversion requires
reinterpret_cast, C-style cast or function-style cast
1>Build log was saved at
1>rrdlib - 1 error(s), 0 warning(s)
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

Any help appreciated. My apologies if this is a noob question. 


Cheers, Barrie

View this message in context: http://n2.nabble.com/Building-rrdtool-v1.3.8-on-win32-tp3169370p3169370.html
Sent from the RRDtool Developers Mailinglist mailing list archive at Nabble.com.

More information about the rrd-developers mailing list