[rrd-users] bug in rrdtool ?

Dan Gahlinger deg at interlynx.net
Wed Dec 18 20:53:01 MET 2002

I've tried everything, and I believe this is a definite bug.

I just tried the tutorial from the website:

I've tried it on both RedHat Linux 8.0 and Solaris (Sparc) v9
and I get the same problem... exponents

Yes, I know 4.0000000000e-02 is the same as 0.04 but it's not as easy to 
read (or graph).
I've tried with whole numbers (from 10-50) and get exponents like 
1.80000000e+01 (18)
yes its the same value, but why is it doing this ?

Most of the time (99%) I get "NaN" regardless of the value used, or how 
rrdtool create/start/etc was done

this is 1.0.40 (latest) rrdtool. And it doesn't graph any of this data 
(even though the values are "correct" - as such).


--There are always possibilities...

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list