[rrd-users] Re: RRDtool update not updating

David Ulevitch davidu at everydns.net
Thu Jan 17 16:25:32 MET 2002

Hello Alex,

Thursday, January 17, 2002, 4:25:24 AM, you wrote:

AvdB> David Ulevitch wrote:

>> That information is all correct.  The problem is that I ran it
>> once from the command line, creating an entry but from then on, I
>> couldn't add entries.  I set cron to run it every 5 minutes and it has
>> no entries and I only see my lone entry when I run:
>> > /usr/local/rrdtool-1.0.33/bin/rrdtool fetch ns1.rrd AVERAGE -s `date +%s`-14400 -e `date +%s`

AvdB> Two possible problems:

AvdB> 1: when run from cron, the program is executed in another directory
AvdB>    and thus the .rrd file cannot be found
AvdB> 2: the PATH environment variable is not setup and thus the "date"
AvdB>    program cannot be found

Thanks all,

It turned out as some of your suspected, I had a path error.  I didn't
include the full path to my rrd files in the perl script and so it was

I appreciate all the help I received.

 David                            mailto:davidu at everydns.net

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list