[rrd-users] RRDTool update, not adding data

henrik at mystat.dk henrik at mystat.dk
Sat Jan 15 14:57:25 MET 2005

I'm new to RRDTool but have been playing around with it for a few days.

Every time i run my rrdupdate it adds the new data, but when I look into the
.rrd-file it doesn't seem to keep the old data, and no data shows up in the
graph. (The SNMP device responds nicely to the commands)

I've tried to manually input data, but it doesn't change the behavior.

I have tried deleting the .rrd fileseveral times.

I've tried different versions of RRDTool on SME Linux 6.0.1 (Based on Redhat

Just before I started going NUTS, I tried the examples from this webpage:
http://ei.kefro.st/projects/rrdtool/ - Again with abselutely NO data!!!

Can ANYONE please help me out of this???

The commands i'm using:

rrdtool create bandwidth.rrd \
--start N \
DS:in:COUNTER:600:U:U \
DS:out:COUNTER:600:U:U \

rrdupdate bandwidth.rrd N:`snmpget -v1 -c public -Oqv
.iso.`:`snmpget -v1 -c public -Oqv

rrdtool graph bandwidth.png \
-a PNG \
-h 125 \
-s -129600 \
-v "Data Throughput" \
'DEF:in=bandwidth.rrd:in:AVERAGE' \
'DEF:out=bandwidth.rrd:out:AVERAGE' \
'AREA:in#00FF00:Bandwidth In' \
'AREA:out#FF0000:Bandwidth In'

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list