[rrd-users] Can't Locate RRDs.pm

MGeneral mgeneral at yahoo.com
Wed Apr 19 00:32:37 MEST 2006

When I run the 4charts.pm example/test script, I get the following error:
Can't locate RRDs.pm in @INC (@INC contains:
/usr/local/rrdtool-1.2.12/lib/perl/5.8.4 /usr/local/rrdtool-1.2.12/lib/perl
/etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8
/usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8
/usr/local/lib/site_perl .) at ./4charts.pl line 6.
BEGIN failed--compilation aborted at ./4charts.pl line 6.

I found several articles suggesting that I run:
make site-perl-install
but that didn't help.  
So I poked around and found the RRDs.pm in the following directory:

and copied all of the contents to:

Now everything seems to work alright, but I wanted to opinions on:
1. Is there any reason the correct files didn't end up in the
$INSTALL_DIR/lib/perl, or the path wasn't set to include the aforementioned
folder (i386-linux-thread-multi)?
2. Is my method of copying the files from i386-linux-thread-multi to
$INSTALL_DIR/lib/perl going to be safe? Or are there other things that I
should move too?

View this message in context: http://www.nabble.com/Can%27t-Locate-RRDs.pm-t1471218.html#a3978185
Sent from the RRDTool - User forum at Nabble.com.

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://lists.ee.ethz.ch/rrd-users
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the rrd-users mailing list