[rrd-users] Problems with Cisco switches

John Oliver joliver at john-oliver.net
Wed Jul 12 18:42:35 MEST 2006

I have some Cisco 2970s I want to monitor.  I'm using a CentOS 4.3
machine with mrtg-2.10.15-1, rrdtool-1.0.49, and routers2-v2.16  I had
tried using rrdtool-1.2.13 but got some error, and Googling for the
error turned up several suggestions to "just use an older version", so I

Anyway... I ran cfgmake against my switches and got configs.  That
worked until I started moving ports into VLANs other than the default.
Once I did that, stats for most ports are no longer collected.  I can
create another conf file with any stanzas and run MRTG against it
manually, and the RRD file is updated.  But as long as MRTG is called
from cron, the RRD files are not updated.

What is going on?  How do I get working stats?  I can snmpget the OIDs
for all ports and get current, valid counters.  Even if I felt like
running MRTG manually, or setting up a million individual little cron
jobs for each port, that wouldn't get the interfaces to show up in

* John Oliver                             http://www.john-oliver.net/ *
*                                                                     *

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://lists.ee.ethz.ch/rrd-users
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the rrd-users mailing list