[rrd-users] Re: Problems with Cisco switches

hkclark at gmail.com hkclark at gmail.com
Wed Jul 12 19:24:40 MEST 2006

On 7/12/06, John Oliver <joliver at john-oliver.net> wrote:
> I have some Cisco 2970s I want to monitor.  I'm using a CentOS 4.3
> machine with mrtg-2.10.15-1, rrdtool-1.0.49, and routers2-v2.16  I had
> tried using rrdtool-1.2.13 but got some error, and Googling for the
> error turned up several suggestions to "just use an older version", so I
> did.

Hi John,

When you say "I started moving ports into VLANs other than the
default", are you changing the VLAN of the port you are polling over?
I assume this probably isn't your issue, but thought I would mention
it just in case.  IOW, if g0/1 is your "uplink port" to the rest of
your network and the one carrying the SNMP traffic, you won't want to
change the VLAN on that (in theory, if it's a trunk, you could change
the VLAN and have it still work [depending on the configuration of the
upstream switch], but that would be a recommended configuration). :-)
But, if ports 2-24 are access ports connected to end-stations, you
should be able to change the vlans on those all day without any issues
re polling.  Also, you aren't changing the anything on the VLAN
interface where the IP address is assigned, right?

Again, those are just quick sanity check things & probably isn't the
problem.  I think the 2970 supports the debug snmp command... that
should be able to tell you if the SNMP gets are making it to the box,
and if so, what the details of those messages is.  It might also be
helpful is you are trying to track down a bug.

Let us know if you get it solved.


Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://lists.ee.ethz.ch/rrd-users
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the rrd-users mailing list