[rrd-users] rrdcached + MRTG

Tobias Oetiker tobi at oetiker.ch
Thu Nov 19 22:14:15 CET 2009

Hi José,

Today José Luis Megías Martín wrote:

> Hi,
> I'm trying to run 'rrdcached + MRTG', but I'm not sure if the following steps are ok:
> I set RRDCACHED_ADDRESS environment variable:
> I run rrdcached as:
>   rrdcached -l <some typical params>
> but when I run mrtg, I get this error message:
>   ERROR: Cannot update file.rrd with '1257937902:14296586674:19866901102' The "RRDCACHED_ADDRESS" environment variable is defined, but "dummy" cannot work with rrdcached. Either unset the environment variable or use "update" instead
> It's necessary to apply some kind of patch to mrtg ?
> What does '"dummy" cannot work with rrdcached' mean ?

this can only work if you run with a unix domain socket ... for ip
access you need an application that is aware of the cached.


> Thanks in advance

Tobi Oetiker, OETIKER+PARTNER AG, Aarweg 15 CH-4600 Olten, Switzerland
http://it.oetiker.ch tobi at oetiker.ch ++41 62 775 9902 / sb: -9900

More information about the rrd-users mailing list