[rrd-users] updating rrd file in context of OCTOPUSSY

lazer a.alii85 at gmail.com
Sun Apr 3 10:15:44 CEST 2011

I'm new to this absolute gem open source marvel aka as 'RRD'. 

Im working on centralized log management software called OCTOPUSSY.  It uses
rrd at the background to display dynamic graphs which gets updated after
like 5 seconds. 

For each syslog source device; there is a .rrd file associated with it for
e.g device_name.rrd. The problem is that i want to add new set of
datasources into the rrd file. 

The graph goes something like this 

As you can see a long list of legends added in the file. All these values
changes in response to number of logs the server received in a certain
amount of times. So the values are not static at all.

I like to add another item in the list e.g Attack.Spoofing...i tried to do
this by exporting the rrd file using the dump command and opening it ....i
added a new data-source as following 



I saved back the xml file and tried to restore using the restore feature
using rrdtools. It won't let me because as it says there is some errror at
line 679 and beyond. I know this is a trivial way of updating the rrd file
...i know there exists a more non-trivial and professional way of updating
the rrd file but right now i don't know how because em new to this whole rrd

the exported rrd file....

View this message in context: http://rrd-mailinglists.937164.n2.nabble.com/updating-rrd-file-in-context-of-OCTOPUSSY-tp6234739p6234739.html
Sent from the RRDtool Users Mailinglist mailing list archive at Nabble.com.

More information about the rrd-users mailing list