[rrd-users] Installing rrdtool on Linux machine

azeddine bezzir a_bezzir at yahoo.fr
Mon Feb 29 11:36:57 CET 2016

Thank you for your feedback.
In fact i downloaded the latest rrdtool package rrdtool-1.5.5, and tried to run the steps decribed in the below url:

I need to identify the dependecies needed, and download them manually as the machine is not directly connected to the internet.
I run the command you proposed 'yum install rrdtool' and got the below output:
Loaded plugins: product-id, subscription-managerThis system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.file:///var/tmp/csnmt-patches/repodata/repomd.xml: [Errno 14] Could not open/read file:///var/tmp/csnmt-patches/repodata/repomd.xmlTrying other mirror.file:///var/tmp/suf-cli/repodata/repomd.xml: [Errno 14] Could not open/read file:///var/tmp/suf-cli/repodata/repomd.xmlTrying other mirror.file:///var/tmp/suf/repodata/repomd.xml: [Errno 14] Could not open/read file:///var/tmp/suf/repodata/repomd.xmlTrying other mirror.file:///var/tmp/csnmt-rpms/repodata/repomd.xml: [Errno 14] Could not open/read file:///var/tmp/csnmt-rpms/repodata/repomd.xmlTrying other mirror.file:///media/rhel/repodata/repomd.xml: [Errno 14] Could not open/read file:///media/rhel/repodata/repomd.xmlTrying other mirror.Setting up Install ProcessResolving Dependencies--> Running transaction check---> Package rrdtool.x86_64 0:1.3.8-6.el6 will be installed--> Processing Dependency: dejavu-sans-mono-fonts for package: rrdtool-1.3.8-6.el6.x86_64--> Processing Dependency: dejavu-lgc-sans-mono-fonts for package: rrdtool-1.3.8-6.el6.x86_64--> Running transaction check---> Package dejavu-lgc-sans-mono-fonts.noarch 0:2.30-2.el6 will be installed--> Processing Dependency: dejavu-fonts-common = 2.30-2.el6 for package: dejavu-lgc-sans-mono-fonts-2.30-2.el6.noarch---> Package dejavu-sans-mono-fonts.noarch 0:2.30-2.el6 will be installed--> Running transaction check---> Package dejavu-fonts-common.noarch 0:2.30-2.el6 will be installed--> Processing Dependency: fontpackages-filesystem for package: dejavu-fonts-common-2.30-2.el6.noarch--> Running transaction check---> Package fontpackages-filesystem.noarch 0:1.41-1.1.el6 will be installed--> Finished Dependency Resolution
Dependencies Resolved
======================================================================================================================================================================== Package                                             Arch                            Version                                Repository                             Size========================================================================================================================================================================Installing: rrdtool                                             x86_64                          1.3.8-6.el6                            rhel-default                          294 kInstalling for dependencies: dejavu-fonts-common                                 noarch                          2.30-2.el6                             rhel-default                           59 k dejavu-lgc-sans-mono-fonts                          noarch                          2.30-2.el6                             rhel-default                          392 k dejavu-sans-mono-fonts                              noarch                          2.30-2.el6                             rhel-default                          450 k fontpackages-filesystem                             noarch                          1.41-1.1.el6                           rhel-default                          8.7 k
Transaction Summary========================================================================================================================================================================Install       5 Package(s)
Total download size: 1.2 MInstalled size: 2.7 MIs this ok [y/N]: yDownloading Packages:

Error Downloading Packages:  dejavu-fonts-common-2.30-2.el6.noarch: failure: Packages/dejavu-fonts-common-2.30-2.el6.noarch.rpm from rhel-default: [Errno 256] No more mirrors to try.  fontpackages-filesystem-1.41-1.1.el6.noarch: failure: Packages/fontpackages-filesystem-1.41-1.1.el6.noarch.rpm from rhel-default: [Errno 256] No more mirrors to try.  dejavu-sans-mono-fonts-2.30-2.el6.noarch: failure: Packages/dejavu-sans-mono-fonts-2.30-2.el6.noarch.rpm from rhel-default: [Errno 256] No more mirrors to try.  dejavu-lgc-sans-mono-fonts-2.30-2.el6.noarch: failure: Packages/dejavu-lgc-sans-mono-fonts-2.30-2.el6.noarch.rpm from rhel-default: [Errno 256] No more mirrors to try.  rrdtool-1.3.8-6.el6.x86_64: failure: Packages/rrdtool-1.3.8-6.el6.x86_64.rpm from rhel-default: [Errno 256] No more mirrors to try.

    Le Lundi 29 février 2016 11h11, Simon Hobson <linux at thehobsons.co.uk> a écrit :

 azeddine bezzir <a_bezzir at yahoo.fr> wrote:

> I want to install rrdtool on a Linux machine, in order to store some statistics files and generate graphs accordingly.
> In fact, it's the first time i am using this tool, and i am unbale to install it, could you support please?
> The OS version is:
> Red Hat Enterprise Linux Server release 6.4 (Santiago)

Your email is really really lacking in detail - how are you trying to install it ? What is going wrong ? What is happening ? What isn't happening ?
See http://www.catb.org/~esr/faqs/smart-questions.html

But in answer to the question I think you are asking ...
I would suggest you simply use the packaged version, I believe on RH systems that would be just "yum install rrdtool". Doing it that way means you'll get a version built for your system, and all the dependencies automatically installed.
If you want to install from source, then you'll need to install dependencies yourself, and you'll need to understand how to configure it for your system (should be a matter of "make configure", but not all packages are that simple).

rrd-users mailing list
rrd-users at lists.oetiker.ch

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.oetiker.ch/pipermail/rrd-users/attachments/20160229/1df2d4c6/attachment-0001.html>

More information about the rrd-users mailing list