[smokeping-users] Slave/Master Again

Stephen Demailly stephen.demailly at thalesgroup.com
Fri Oct 12 12:26:55 CEST 2007

hello tobi,

I just feel stupid .... here is my simple config file

============================== config ======================================
*** Probes ***

+ FPing
binary = /usr/local/sbin/fping
packetsize = 256

*** Slaves ***

+ slave1
color = 0000ff

+ slave2
color = ff00ff

*** Targets ***
slaves = slave1 slave2

menu = Top
title = Network Latency Grapher
remark = Welcome to the SmokePing website Here you will learn all about 
the latency of our network.
probe = FPing

+ Tcis
menu = Tcis Server
title = TCIS Server
host = tcis.domain
slaves= slave1 slave2 <==== THIS IS LINE 158

+ TrtWeb
menu = TrtWeb Server
title = TRTWEB Server
host = trtweb.domain
slaves= slave1 slave2

+ KMWeb
menu = KM Server
title = Knowlege Managagement Server
host = trt.domain
slaves= slave1

============================== End config 

Result :

Enter h or `h h' for help, or `man perldebug' for more help.

14:     Smokeping::cgi("/usr/local/smokeping/etc/config2");
  DB<1> c
Content-type: text/html

<h1>Software error:</h1>
<pre>ERROR: /usr/local/smokeping/etc/config2, line 158: slave1 [slave2] 
For help, please send mail to this site's webmaster, giving this error 
and the time and date of the error.

[Fri Oct 12 12:19:56 2007] smokeping2.cgi: ERROR: 
/usr/local/smokeping/etc/config2, line 158: slave1 [slave2]
Debugged program terminated.  Use q to quit or R to restart,
  use O inhibit_exit to avoid stopping after program termination,
  h q, h R or h O to get additional info.

Tobi, I have also tried with other slaves names such as slave_a slave_b 
or realname1 realname2 ... nothing is working.



Tobias Oetiker a écrit :
> Hi Stephen,
>> Things appears to work much better. Looking at the logs I finally found why my rrd could not be
>> updated : It was because the apache daemon running with user:group apache:apache could not have write
>> access to the /usr/local/smokping/var where the ~slave.rrd files where located on the master (because
>> smokeping.cgi is run by apache, not root).
> note that you might want to run smokeping unter a user account and
> user suexec in your apache config to run cgis under that user
> account as well.
>> So everything is OK now, but I still  have one question  which is not answered :
>> Assuming I have three environment, say envA, envB, envC containing host and objects to be measured,
>> and assuming I want Master to poll envA, envB, envC and Slave to poll only envA, envB (because envC
>> is not reachable form the Slave), how do I set the "slaves=" directives in order to tells the slave
>> not monitoring envC ???? I have tried to set the "slaves=" directive specifically to envA and envB
>> but I have the "ERROR: /usr/local/smokeping/etc/config, line 312: slave1 [slave2]" message.
> I guess this is a syntax error ...
> you can configure which slaves get which target by putting a]
> +dest1
> host = ip1
> slaves = slave_a slave_b
> +dest2
> host = ip2
> slaves = slave_a slave_b
> +dest3
> host = ip3
> slaves = slave_a
> cheeers
> tobi
>> Cheers to all of you,
>> Stephen.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: stephen.demailly.vcf
Type: text/x-vcard
Size: 443 bytes
Desc: not available
Url : http://lists.oetiker.ch/pipermail/smokeping-users/attachments/20071012/842e6358/attachment.vcf 

More information about the smokeping-users mailing list