[smokeping-users] SmokePing, Ubuntu, and Permission Errors

Richey mylists at battleop.com
Tue Apr 15 00:06:20 CEST 2008

I am not worried so much about permissions.  The box is behind a Pix
firewall and I am the only human that works off of that network.  All other
employees are behind another firewall.   I've messed with chown for root and
www-data and still no luck.     When I navigate to
http://localhost/smokeping I just get a directory listing like below there
are not any .htm files that I would expect.  





Index of /smokeping


Name              Last modified Size Description



Parent Directory


- Media_mini.png 14-Apr-2008 09:18 11K

rrdtool.png       14-Apr-2008 09:18 3.8K

smokeping.png     14-Apr-2008 09:18 4.3K



Apache/2.2.4 (Ubuntu) Server at Port 80





From: Nathan Long [mailto:nathanlong at gmail.com] 
Sent: Monday, April 14, 2008 8:35 AM
To: Richey
Subject: Re: [smokeping-users] SmokePing, Ubuntu, and Permission Errors


I had similar issues with Smokeping and Ubuntu.  To fix the problem I had to
give ownership of the folder /var/lib/smokeping and rrd files inside to
root, and ownership of any slave_cache files (if you're using slaves) to
www-data.  I'm not sure of the security risks involved with this, but it's
working for me.


On Mon, Apr 14, 2008 at 7:57 AM, Richey <mylists at battleop.com> wrote:

I am trying to get Smoke Ping running  on Ubuntu 7.10 - Gutsy Gibbon with
Apache2.  I can't get the graphs to do anything.  When I look at
/var/log/messages it's full of:

Apr 11 07:40:38 toybox4 smokeping[5565]: RRDs::update ERROR: opening
'/var/lib/smokeping/Media.rrd': Permission denied
Apr 11 07:40:38 toybox4 smokeping[5565]: RRDs::update ERROR: opening
'/var/lib/smokeping/Local/LocalMachine.rrd': Permission denied

Googleing, I found a post that says that you need to change the ownership of
the files in /var/lib/smokeping/* to apache.  I think that ubuntu runs
apache as www-data.  So I have tried to change the ownership of the files to
both apache and www-data.   I still get the same results.   Are there maybe
some files in other places that need a change of ownership or permissions? 
I have also messed with the ownership of /usr/lib/cgi-bin/smokeping.cgi.

I've messed with this off and on for a few weeks.  Ten minutes here ten
there so I am sure I am over looking something simple.


smokeping-users mailing list
smokeping-users at lists.oetiker.ch


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/smokeping-users/attachments/20080414/adcd3738/attachment.html 

More information about the smokeping-users mailing list