[smokeping-users] Smoketrace - can't open ICMP socket

Todd Volz todd at stir.org
Fri Mar 20 01:03:15 CET 2009

I am running Smoketrace out of smokeping 2.4.1 and have just installed it on opensuse 11.1.  I'm not using any of the smokeping polling or graphing, I'm just interested in the SmokeTrace application. I have had it working on a slackware 11 install. 

The Problem: 
I get the Smoketrace interface loaded in the browser window, with the correct IP address, however when it tries to start pinging, it pauses for a few seconds and then displays the message: "unable to create ICMP send socket: Operation not permitted"  

I have searched through the code for SmokeTrace (TR.pm) and can't find anything that would even be giving that error. 

I have tried to run the traceroute as a user on the machine, and as root, no problems .  I don't get any errors in the apache logs.  I have tried shutting off AppArmor (Suse application based firewall)  and the Firewall, nothing has helped.  I have tried looking on google, but nothing has come up through google or this mailing list archives.  any hints as to other places to look for the problem? 

Are there any debug options that can be turned on to get a little more information as to where this error message is coming from so I can try to get it working? 

Thanks for any sugestions. 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/smokeping-users/attachments/20090319/7f52bdab/attachment.html 

More information about the smokeping-users mailing list