[smokeping-users] ERROR: opening '/tmp/smokeping-ms/data/mysite1/myhost1.rrd': No such file or directory

Layla Nahar laylanahar at gmail.com
Wed Jul 27 13:34:40 CEST 2011

Hi,  I'm getting this error:

When I click on a menu item (eg 'MySite1) I get the failure.
ERROR: opening '/tmp/smokeping-ms/data/mysite1/myhost1.rrd': No such
file or directory

Can somebody tell me how to fix this?

I set tmp/smokeping-ms/data to permission 777 and I set ownership of
both 'smokeping-ms' and 'data' to smokeping:smokeping.  I also tried
setting ownership to apache:apache but I still get the failure above.

I am doing everything as root.  I started smokeping as user root.

root is able to run RRDTool and make a new *.rrd file
user smokeping is able to run  "rrdtool --help"  but gets a permission
denied error when trying to create an *.rrd file.

Is the source of
ERROR: opening '/tmp/smokeping-ms/data/mysite1/myhost1.rrd': No such
file or directory
in the permissioning?

How can I fix this error?    I can set up new users and groups if
necessary.  I've noticed references to user 'www' but I have yet to
set up this user.   I guess that it is related to apache.  It would be
great if someone could clarify the role of www.

thank you very much


More information about the smokeping-users mailing list