[smokeping-users] Error after attempting to restore Smokeping after fresh install

smokeping at daxm.net smokeping at daxm.net
Fri Mar 17 12:54:56 CET 2017

Solved it.  Apparently the newer version of smokeping requires a 
'urlformat' variable for Curl.

I needed to add the following in my Targets' Curl section:

urlformat = http://%host%/

Alas, I also had to delete all my RRD data from the previous install in 
order to get smokeping to load properly.  Oh well, starting from scratch 
once again.  :-(

On 03/13/2017 04:20 PM, smokeping at daxm.net wrote:
> You are correct, I should have provided more information.  My apologies.
> I went from LinuxMint 17 to LinuxMint 18.  I used the "apt-get install 
> smokeping" option BUT I did restore from backup my /var/lib/smokeping 
> folder as well as my Targets file.  (I had to edit/add things to my 
> Probes file but that wasn't too hard).
> On 2017-03-13 13:14, Gregory Sloop wrote:
>> Re: [smokeping-users] Error after attempting to restore Smokeping 
>> after fresh install
>> 	I updated my system with a fresh install of Linux.  I **thought** 
>> that I had gotten all the important files backed up but apparently I 
>> missed something regarding smokeping.
>> Here is a sample of an error I'm getting now when I attempt to access 
>> my smokeping webpage:
>> ERROR: /etc/smokeping/config 
>> (Targets/HTTP/dcloud_cisco_com/dCloud_us): mandatory variable 
>> 'urlformat' not defined
>> The Target that it complains about changes randomly if I reload the 
>> webpage but the basic error remains the same.
>> I've tried to Google for a solution but I get no hits on my search.
>> Any smokeping gurus out there know the solution to my problem?
>> I don't have an answer off the top of my head.
>> I assume this was a new install of a different distro?
>> It might be helpful to know what distro, and what the distro version 
>> was before and after.
>> Same for smokeping - version prior/after.
>> -Greg
> _______________________________________________
> smokeping-users mailing list
> smokeping-users at lists.oetiker.ch
> https://lists.oetiker.ch/cgi-bin/listinfo/smokeping-users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.oetiker.ch/pipermail/smokeping-users/attachments/20170317/62ee6d45/attachment.html>

More information about the smokeping-users mailing list